Roll Forward a Document or Project

There are two primary methods for rolling forward projects without XBRL, copying the project from Admin and exporting then importing a project. If the project you are rolling forward does not include all linked documents, links in the subsequent project will not work correctly. When rolling forward, you can choose certain parts of the project to retain, such as comments. This article will explain how to use both methods. For projects with XBRL, see Rolling Forward a Project with XBRL.

If you encounter problems, however, please contact your Customer Success Manager.

Method 1: Copying a Project from Admin

If you are an account administrator, you can quickly copy a project from the Admin panel. First, go to the Content tab and click the name of the project you'd like to copy.

image alt text

From the project details page, click Copy Project to begin creating a copy of the project.

image alt text

You will have several Project Copy options, including: Email on completion, Use original supporting documents, Copy comments and Copy outline labels. If you choose the first option, you will receive an email alerting you to when either a successful or failed project copy has been completed.

You will also be able to view the history and results of any project copy at any time on the Copy Status page of the Content tab.

Project Copy may take several minutes, though you may do other tasks in Wdesk while this process happens. You can check the status of a project copy at any time from the Copy Status sub-tab.

When complete, a duplicate of the project named "Copy of" followed by the copied project's name will be available in your projects and documents list from Home.

After your project has successfully been copied, you should update your project details for the new filing. See "Update Project Details" at the bottom of this article for more information.

NOTE: Any Tasks associated with a project will not carry over during a Project Copy.

TIP: You can set dates in one part of a document, then link the dates throughout the rest of the document. Utilizing linking, you can update dates once, and all linked dates will automatically update in all locations. To learn more, read the article Linking Overview.

Method 2: Exporting and Importing a Project

Exporting a Project

Permissions will revert to default settings when a project is exported. To save current permissions, save a permissions set or contact a CSM for assistance.

  1. Open the Project and click Export Project in the Projects panel.

    image alt text

  2. A dialog box appears, asking to include comments in documents contained in the project as well as supporting documents. Include comments if needed, but it is not recommended to include comments if the project will be rolled forward. Finally, click Export Project.

  3. A dialog box is displayed, asking to include XBRL data in your export. This article relates to projects that do NOT contain XBRL. Therefore, click No.

  4. A status box displays the progress of the export. The duration of the export is determined by the number of documents, size of your documents, number of links, etc. contained in the project.

  5. A dialog box appears, prompting to save the export. Click OK and select the location to save the .zip folder containing the XML file(s). NOTE: Do not change the name of the .zip file or the exported project. Doing so may prevent import of the project.

  6. Click Save to complete the export.

Exporting a Document

Exporting a document will create a .zip file containing the selected document and any documents sharing links with the document. Please contact a CSM with questions regarding document export. Permissions will revert to default settings when a document is exported. Save your permissions as a set or contact a CSM for assistance.

  1. Open the Document and click Export in the File tab.

    image alt text

  2. A dialog box appears asking to include comments contained in the document. Include comments if needed. Click Export File.

  3. A dialog box appears asking to include XBRL data in the export. This article relates to documents that do NOT contain XBRL. Therefore, click No.

  4. A status box displays the progress of the export. The duration of the export is determined by the number of linked documents, size of documents, number of links, etc.

  5. A dialog box appears prompting to save the export. Click OK and select the location to save the .zip folder containing XML file(s). Do not change the name of the .zip file or the exported project. Doing so may prevent import of the document.

  6. Click Save to complete the export.

Importing a Project

  1. On the File tab, click the Import button.
  2. Select Document or Project and browse to the .zip file.
  3. Review the package contents in Import New Project and verify all applicable and linked documents are included.
  4. In the Import Project Options dialog box, under Supporting Documents Preferences:
    1. Specify action when file names do not conform with SEC rules.
      1. The default setting, Ask Me, prompts you to accept a suggested filename or keep the current filename when it does not conform to SEC rules.
      2. Select Accept Change to change non-conforming filenames without prompts.
      3. Select Keep Current to automatically keep the existing name.
    2. Specify action when a duplicate filename is detected.
      1. The default setting Ask Me prompt appears when a duplicate file name is detected in the account.
      2. Select Overwrite Existing to automatically overwrite the existing file name (without prompts). NOTE: Image names cannot be overwritten.
      3. Select Create New to automatically create a new file when a duplicate file name is detected.
  5. Click Next.
  6. Select the Period End Date.
  7. Select the Target Filing Date.
  8. Click Import Project.
  9. If XBRL was not turned on prior to import, a dialog appears asking to import the XBRL data included in the project. Click Yes. XBRL dates can be rolled-forward after the Import completes.
  10. The import completes and project contents are visible in the Projects panel.

Updating Project Details

After import, contents of the project appear in the Project tab. Imported document names contain (1) to avoid overwriting the original files.

  1. Click Project Properties icon in the Projects panel.
  2. Update the Project name, verify period end and target filing date, and set Project permissions.

image alt text

NOTE: Much of the information will auto-populate from Admin settings and can be changed at a later date if necessary.

3. In the right-hand Project panel, on the Documents tab, right-click a document name, choose Rename, and rename all documents (10-Q, Exhibits, etc.).

4. Set permissions for each document.

TIP: It is best practice to utilize the current reporting period end date in document names. For example,EX 03.31.2014 99.1 Press Release would roll-forward to EX 06.30.2014 99.1 Press Release when rolling from Q1 2014 to Q2 2014. This document name will be used as the filing document name as well.

Cleanup and Review

Once project details have been updated, you should review your document to ensure that all information is correct. You may encounter validation errors if all information is not updated.

  1. Open the workbook and update the period end date.
  2. Check the document to ensure all dates are linked and rolled forward. For example, if rolling from Q2 to Q3, verify six months has changed to nine months, second quarter has changed to third quarter,etc.
  3. Check for updated dates on the signature page and exhibits.
  4. Update hyperlinks as necessary.
  5. Validate the document.