Spreadsheet Basics

Adding Sheets

To add a new sheet to your Spreadsheet outline, click Add Before or Add After at the top of the document outline panel. You can add up to 100 sheets to one Spreadsheet document. If you need to create a new Spreadsheet document, see Creating and Importing Spreadsheets.

image alt text

You can move a sheet in or out a level using the Promote or Demote button at the top of the document outline panel. You can also move it up or down a level in the outline with the Move Up or Move Down buttons.

image alt text

Changing Spreadsheet Permissions

Once you add a sheet to your document, you can change permissions for an individual sheet. Right-click the sheet in the document outline and choose Sheet Permissions.

image alt text

On the Permissions screen, find the user you'd like to change in the list. Then click the permission level next to their name to grant them that permission.

  • Viewers can view a sheet, but not edit it.
  • Editors can change a sheet's contents.
  • Owners can modify a sheet's contents, as well as delete a sheet permanently.

    image alt text

Formatting in Spreadsheets

In Spreadsheets, the cell and text formatting options are in the Edit tab. From there, you can format text, select cell alignment, and change number options. You can also insert or remove rows and columns, as well as lock cells from this tab. If you'd like to use a color that is not in the color selector, you can enter the six digit hexadecimal code for your desired color in the field at the bottom of the color selector.

Additionally, you can choose a formatting type for a cell so that data entered in the cell will have some formatting automatically applied. Cells are set to Automatic by default, but entering a currency symbol or comma separator will change the formatting to Accounting.

Using Entered In and Shown In

You can adjust the precision of numbers in your Spreadsheet using the Entered In and Shown In options. Highlight a cell or range, then go to the Edit tab and select an option for Entered In to scale the values you enter or Shown In to define how to display the values. The displayed value of a cell may change based on these selections, but the exact value of the cell remains.

image alt text

Using Period Format and Display Options

You can choose how to display numbers in your Spreadsheet using the Period Display options in the cell Properties panel. This allows you to use the proper ISO format for XBRL, which is PnYnMnD. For example, if the life left in a building is 5.7 years, the ISO format is P5Y7M12D. To display that number as the more common 5.7 decimal number, use the Period Display options.

For more information about formatting decimals for XBRL, see Formatting Time Period Links - ISO Codes.

To change the period format, make sure you format the cell or range as Period from the Edit menu. Then select the cell or range and open the Properties panel on the right by clicking the gear icon.

Click Formats and click the Display drop-down to open the menu. Select an option to format the period placement. The cell value changes to the period format you select, but the exact value of the cell remains.

image alt text

Sorting Data

You can sort data in one column or for the entire table using the Sort feature from the Data tab. Select a column or data range to sort and click Sort from the Data tab.

image alt text

For a data range, specify if the range includes a header row or not, select which column you want to sort, and how you want the data sorted. Then click Sort.

image alt text

Hiding Rows and Columns in Spreadsheets

If you would like to hide rows or columns so they remain in your document but are not visible, you can use the Hide feature.

Click the header for the column or row you'd like to hide to select the entire column or row. You can select consecutive columns or rows by holding shift and clicking a column or row header. You can also select a group of rows or columns by dragging your mouse over them.

After making a selection, click Hide in the Edit toolbar and choose Hide Columns or Hide Rows.

image alt text

Viewing Overlays in Spreadsheets

You can view locked cells, value formatting, or how numbers are entered and shown for your data at a glance using the Overlays feature in the View tab.

Click Overlay from the View tab to open the Overlay Legend tab in the right-hand panel. Click the arrow next to Overlay Legend to open the drop-down menu where you can select the type of overlay you want to view, as well as see a legend for the selected view.

image alt text

Freezing Columns or Rows in Spreadsheets

Freeze locks one or more columns or rows in place while the rest of the Spreadsheet is free to scroll. This feature is especially useful when working with large Spreadsheets. You can use Freeze at any time. Freeze is turned on and off by choosing the Freeze or Unfreeze from the View tab.

image alt text

Selecting a column will freeze it and all columns to the left of the selection. You can select the column by clicking the letter at the top. To unfreeze the columns, select the View tab and click Unfreeze in the toolbar. Selecting a row will freeze the selected row and all rows above the selected row. You can unfreeze by clicking Unfreeze again from the View tab.

If you choose the top cell in the column, the column to the left is frozen, but not the column for the chosen cell. Now, you can scroll horizontally to compare data in different columns as needed.

Selecting a cell deeper in the Spreadsheet will freeze all rows above the selected cell and all columns to the left of the selected cell. In this case you can scroll both vertically and horizontally.

image alt text

Merging Cells

To merge cells in a Spreadsheet, select the cells you want you to merge, right-click, and select Merge Cells. You can choose to merge cells horizontally or vertically, merge them all together into one larger cell, or unmerge them.

image alt text

Exporting a Spreadsheet

You can also save a local copy of your Spreadsheet as a .csv or .xlsx if needed. Click Export, then choose the file type to save as.

image alt text

If exporting as .xlsx, the file will download to your default download location. When exporting a .csv file, choose whether to export one or all sheets and whether to include formulas. Then click Export to save to your default download location.

Accessing Home from Spreadsheets

When you are working in a spreadsheet, you have ongoing access to return to the Home Menu at any point. Simply hover over any of the icons on the vertical bar on the far left. This activates the drawer with all of the menu options available in Home.

Once you choose a menu option, the full Home interface will open and display all items for that tab.